Archive for the ‘EIGRP’ Category

h1

EIGRP adjacency using a secondary IP

November 27, 2010

Consider the following statement from Cisco.com : “Routers do not form EIGRP neighbors over secondary networks.

A Routing-BitsHandbook candidate queried this last week, claiming the statement is misleading and that EIGRP will indeed form an adjacency using a secondary IP address under specific conditions.

Consider the following configuration. R1 connects to R2 using a back-to-back serial connection. Both S1/1 interfaces have a primary and a secondary IP address defined. The EIGRP processes only matches the secondary IP addresses.

R1#
interface Serial1/1
ip address 10.1.1.1 255.255.255.0 secondary
ip address 10.5.1.1 255.255.255.0
!
router eigrp 1
network 10.1.1.1 0.0.0.0
no auto-summary

R2#
interface Serial1/1
ip address 10.0.1.2 255.255.255.0 secondary
ip address 10.5.1.2 255.255.255.0
!
router eigrp 1
network 10.0.1.2 0.0.0.0
no auto-summary

So what do you think will happen in this scenario? Will R1 and R2 become adjacent? Cisco explicitly mentions that a secondary IP address is not used in the EIGRP hello packets, therefore EIGRP neighbors will not become adjacent using secondary IP addresses.
Read the rest of this entry ?

Advertisements
h1

R&S Quick Notes – IGP’s

May 18, 2009

RIP

  • Know your filters: Offset-list, Distribute-lists, distance command.
  • With filters read carefully: “between 25 & 45” or “from 25 to 45”.
  • Know your prefix-lists or alternatively using ACL’s instead.
  • “passive interface” command, ONLY stops the sending of updates out the interface. Interface will still receive and process those updates. Passive interfaces will still be advertised in other updates.

EIGRP

  • Advertising a default route out one interface: “ip summary-address eigrp [AD] 0.0.0.0 0.0.0.0”
  • To see if a neighbor is configured as STUB, “show ip eigrp neighbors [detail]” as look for ‘CONNECTED SUMMARY’
  • On frame-relay multipoint interfaces, don’t forget to disable split-horizon.
  • External EIGRP routes AD (admin distance = 170) can NOT be changed on per prefix basis.
  • Metric weight values:
    1 0 1 0 0 = Default
    0 0 1 0 0 = Only DLY
    1 0 0 0 0 = Only BW
    3 0 1 0 0 = BW has 3 times more weight reference than DLY
  • Metric formula:

Metric = ((107 / BW) + (DLY/10) ) * 256

OSPF

  • The Neighbor IP used with OSPF distance command is the Neighbors Router-ID.
  • “area range” summarize type 3 LSA’.
  • “summary-address” summarize type 5 & 7 LSA’s.
  • Auto-cost reference BW (Default = 100mb), formula = Ref-BW/Int-Bw.
  • Switches do no support the interface command “ip ospf {pid} area {area-id}” .
  • OSPF path selection: O > O*IA > O*E1 > O*E2.
  • Using E1 metric type : Packets will be routed out the closest exit point of the network.
  • Using E2 metric type : If you want packets to exit your network at the closest point to their external destination.
  • Don’t forget with hub and spoke topology, “ip ospf priority 0”.
  • PITFALL, when forbid to use RID, Loopbacks created later on might change the DR on you network after a reload.
  • PITFALL, when forbid to use RID, Later requested to configure the same loopback on two routers, could break your adjacencies, as two router cant peer with the same RID.
  • “no capability transit” – Mimics OSPFv1 behaviour for all data traffic to pass through Area-0.
  • “max-metric” – Configures OSPF stub configurations
  • “max-lsa” – Limit amount of non-local LSA’s
  • “timers throttle lsa all” – Slow down update rate.
  • “timers pacing lsa-group” – Group more LSA’s together in updates.
  • “no ip ospf flood-reduction” – Disables every 30-min LSA DB refresh.
  • “ip ospf database filter all out” – Breaks RFC, Stop sending LSA’s, but still receive LSA’s

h1

Eigrp Metric Manipulation

April 2, 2009

One of the great unique features EIGRP brings to the table is the ability to load-balance traffic across unequal links.

eigrp

To properly configure R1 to load balance traffic on a 5:1 scale to network 164.1.26.0 we need to understand how the EIGRP composite metric.
The composite metric consists of
– BW : the minimum bandwidth of any outgoing interface along a specific path
– Delay : the cumulative delay of all the outgoing interface along a specific path
– Load : effective load of a route on the interface
– Reliability : likelihood of successful packet transmission
– Smallest MTU along a path.

There is a big long formula that takes each of the above metrics into account using specific K-values. But I’m not going to cover that here. The only thing of importance is that the K-values could be changed to en/disable some of the above metrics
By default, only BW & Delay is taken into account when calculating the metric according the the following shorten formula:
Metric = 256 * ((10^7/BW) + (DLY/10))

Let look at a example on R1:

eigrp-11

Read the rest of this entry ?