h1

Output101- sh run vrf

September 4, 2010

Now that the hard work is behind me, the awesome holiday has past, I can finally get back to all the outstanding fun stuff. That said I have some good half completed posts are on the way :)

I came across the following command browsing the DOC-CD a couple months back, and I have used it ever since.

sh run vrf [vrf-name]

The show running vrf feature provides the option to display a subset of the running configuration on a router that is linked to a VRF instance. It can be used to display the configuration of a specific VRF or of all VRFs configured on a router. The command is unfortunately only available on the more recent IOS versions, but if available makes life easy.

Example output showing all related VRF-BOB configuration:

PE-Router# show run vrf BOB
Building configuration...

Current configuration : 604 bytes
ip vrf BOB
 rd 100:3
 route-target export 100:3
 route-target import 100:3
 maximum routes 3000 100
!
!
ip route vrf BOB 155.5.0.0 255.255.0.0 10.5.2.2 global
!
!
interface Loopback0
 ip vrf forwarding BOB
 ip address 10.5.15.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding BOB
 ip address 10.5.0.1 255.255.255.0
 no ip redirects
 duplex half
!
!
router ospf 101 vrf BOB
 log-adjacency-changes
 area 1 sham-link 10.5.15.1 10.5.15.5 cost 10
 network 10.5.0.0 0.0.0.255 area 1
!
!
router bgp 100
!
address-family ipv4 vrf BOB
 redistribute connected
 redistribute ospf 101 match external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family
 !
end
Advertisements

Please leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s