Understanding and Configuring a HWIC-3G-GSM

Apologies for the long absence from posting. I find myself without any hours left in a day before I got to everything I wanted to do.  And before you know it, more than a month has gone past.

In my previous post I presented a quick solution to an Out-of-Band network and I talked about some options. I’ve had mails asking how to show some of the configurations. I’ll cover those and do other posts I have been promising in the next couple days.

This post will focus on the current Cisco 3G WAN card, the HWIC-3G-GSM. This card is supported by Cisco’s 1841, 1861, 2800-series and 3800-series ISR routers. This card only supports High-Speed Downlink Packet Access (HSDPA) “up to” 3.6 Mb/s downlink, 384 kb/s uplink (presumably HSDPA Category 5/6, but not sure)

“3G” is a broad category of standards and services around “broadband” mobile wireless voice and data. Universal Mobile Telecommunications System (UMTS) is part of this family. High Speed Packet Access (HSPA) is a collection of mobile telephony protocols that extend and improve the performance of existing UMTS protocols. Two standards, HSDPA and HSUPA have been established and is fairly well known.

Three components are required to use a 3G data connection: a SIM, a radio modem, and a router. The SIM identifies the subscriber (that is you the human) for billing and so forth. The radio modem does the hard work in providing physical layer (Layer1) access to the local 3G base station. The router typically uses PPP as the Layer2 data link to the provider’s Network Access Server (NAS), and from there is connected to the provider’s Layer3 network (which may be a private VPN, or public Internet).

The cellular modem must establish a data call, then once connected a PPP session is established to the providers NAS. The cellular modem still requires age-old AT commands to make that call, and additionally to interrogate the SIM, etc. Cisco IOS provides an interface to a handful of modem features via the “cellular” exec command and a chat script(s). Note that AT commands can only be issued when the modem is idle (not in a call).

The modem is configured with at least one “profile” which stores an Access Point Name (APN) and optionally a username and password. This profile is then “dialled” to establish the connection similar to using a traditional phone number. These modem profiles are stored on the modem and NOT on the routers NVRAM or flash. Note that a modem profile and an IOS dialer profile are two separate things.

The HWIC-3G-GSM is just a Sierra Wireless MC8775 modem sold in a HWIC form factor with a Cisco Logo on it. The modem is presented in Cisco IOS as two interfaces:

  • Low-speed asynchronous “control” interface which communicates with the modem.
#line x/x/x
  • High-speed synchronous interface connecting to the cellular providers network.
#interface cellular x/x/x

Yes that means you can actually do a reverse telnet to the modem, and configure the AT commands natively. Should you do it? NO, unless you know what you doing.
There is also a physical “diag” port (refer to the picture above) on the front of the WIC for low level debugging of the modem. That is just to tease you. You need proprietary software to use that port.

Enough boring stuff. The HWIC-3G-GSM card has RSSI (Received Signal Strength Indication) LED in the front, (refer to picture again) to indicate the 3G signal strength. The index is as follow:

  • Solid Yellow: No service
  • Off – Low RSSI (under -100 dBm)
  • Slow Green Blink: Low or medium RSSI (-99 to -90 dBm)
  • Fast Green Blink: Medium RSSI (-89 to -70 dBm) [ideally this should be a minimum]
  • Solid Green: High RSSI (-69 dBm or higher)

.

Configuring this simple little card.

Firstly the 3G-GSM card requires at least Cisco IOS 12.4(15)T1 but I would recommend a higher version for stability purposes.
For the Cisco-1841 I downloaded c1841-advipservicesk9-mz.124-24.T3.bin because I needed the extra IOS features.

By default most new SIM cards are protected with a PIN code before they could be used (This per Session). This PIN code should be disabled when used with a HWIC-3G-GSM.
To see if the SIM card has a PIN code active issue the following command:

sh cellular 0/0/0 security                        '!! HWIC insert to slot 0 !!'

To remove the PIN issue the following command:

cellular 0/0/0 gsm sim unlock 1234                 ' !!Enter the PIN !!'

Then issue the previous show command again to get a output similar to this:

.

Next the actual configuration which is required. This configuration might vary based on the cellular provider used (chat-script). Secondly how you plan on using it, tunnel types  or plain etc. I will show the config I used to connect to Vodacom South-Africa and using a straight forward cellular interface to connect to anthe Vodacom Internet APN. A PPP tunnel or dialer interface could also be used but it all depends on what you want to accomplish.

I will explain the configuration I used where needed:

Firstly define your providers AT command in a chat-script

!
chat-script gsm "" "ATDT*99#" TIMEOUT 30 CONNECT
!

Next you need to configure your line information:

line 0/0/0                          '<---This will depend on what slot the card uses'
 exec-timeout 0 0
 script dialer GSM                  '<---Calls the chat-script'
 modem InOut
 no exec
 transport preferred none
 transport output none

Then the interface and NAT and other configurations

username 3g-hwic password password       '<--- Specifies the username and password used'
!                                                   ' either locally or for the APN'
!
dialer-list 2 protocol ip permit         '<--- Specifies interesting traffic to bring up the dialer'
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.255
!
interface FastEthernet0/0
 description INSIDE
 ip address 10.0.0.1 255.255.255.0
 ip nat inside                           '<--- NAT needed when coming from private addresses'
 ip virtual-reassembly
!
interface Cellular0/0/0
 description APN-FACING
 ip address negotiated                   '<--- The NAS will issue your card an IP address'
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 0
 dialer string GSM                       '<--- Again uses the chat-script'
 dialer-group 2                          '<--- References the dialer-list (interesting traffic)'
 async mode interactive
 ppp chap hostname 3g-hwic               '<--- Username and password is required.'
 ppp chap password password              '<--- Local or Providers APN'
 ppp ipcp dns request
!
ip nat inside source list 2 interface Cellular0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
access-list 2 permit any

(You might ask why I configured the username and passwords I did above? That is still required, even if it is just used locally.)
(But what if you must authenticate to the cellular provider? Then all that is needed extra is to define the APN username and password in the modem profile below.)

.

Lastly the APN must be specified in the modem profile (Here I connected to the Vodacom APN “internet” without any authentication as Vodacom does not require any.

VODACOM#cellular 0/0/0 GSM profile create 1 internet
  Profile 1 will be created with the following values:
  APN = unrestricted
  Are you sure? [confirm]
  Profile 1 written to modem

.

Verify the profile:

VODACOM#sh cellular 0/0/0 profile

Profile 1 = INACTIVE*                '<--- NOTE inactive, Cellular still down'
--------
  PDP Type = IPv4
  Access Point Name (APN) = internet
  Authentication = None
  Username:  Password:

.

Since we using a DDR config, the Cellular interface will only be brought up if there is interesting traffic, either real traffic or traffic created by IP SLA or from the command line.

VODACOM#ping 168.210.2.2

Type escape sequence to abort.
  Sending 5, 100-byte ICMP Echos to 168.210.2.2, timeout is 2 seconds:
  ...!!
  Success rate is 40 percent (2/5), round-trip min/avg/max = 92/106/120 ms

*Mar  3 10:37:58.499: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up

.

Verify the profile again to confirm all is working:

VODACOM#sh cellular 0/0/0 profile

Profile 1 = ACTIVE*                 '<--- NOTE now its active, Cellular is up'
--------
  PDP Type = IPv4
  Access Point Name (APN) = internet
  Authentication = None
  Username:  Password:
Advertisement

34 thoughts on “Understanding and Configuring a HWIC-3G-GSM

  1. Our modem used to disconnect sometimes or was not willing to connect. Clear interface, clear dialer, shutdown methods would not help. In this case the modem must be reset or restarted (if you want to avoid a router reload)

    (config)#service internal
    (config)#exit
    #test cellular 0/0/0 modem-reset

    or

    (config)#service internal
    (config)#exit
    #test cellular 0/0/0 modem-power-cycle
    (this is better)

    So why not automate the process? (-:

    event manager applet 3G-reset
    event syslog occurs 3 pattern “UNBIND: Interface Ce0/./0 unbound from profile Di0” period 300
    action 1.0 cli command “enable”
    action 2.0 cli command “configure terminal”
    action 3.0 cli command “service internal”
    action 4.0 cli command “end”
    action 5.0 cli command “test cellular 0/1/0 modem-power-cycle”
    action 6.0 syslog msg “EEM Cellular modem power cycled”

    The generalized AT command is:

    ATD*gprs_sc*CID#

    where gprs_sc can be
    99 (GPRS Service Code) a digit string (value 99) that identifies a request to use the Packet Domain service.
    98 (GPRS Service Code) a digit string (value 98) that identifies a request to use the IP service

    CID (PDP Context Identifier) is the profile number (1..16). There can be multiple profiles in the modem. Apparently, 1 is the default and *1 can be omitted.

    So ATD*99*1# or the simpler ATD*99# are the most common dial strings.

    1. Your modem should not disconnect without intervention.
      It sounds like the keep alive signal might be incompatible between your modem firmware and your cellular provider.
      Although the EEM srcipt is a nice quick hack, I would suggest you contact your cellular provider to enquire what hardware version they require for their equipement.
      Keep in mind different Providers use different firmwares, and some dont support the Sierra Wireless MC8775 modem.
      Refer to this link:
      http://www.cisco.com/en/US/prod/routers/networking_solutions_products_genericcontent0900aecd80601f7e.html

      Then I would suggest changing your firware to the compatible version.
      Refer to this URL on the step :)
      http://www.cisco.com/en/US/partner/docs/routers/access/1800/1861/software/feature/guide/3ghwic.html

      Ps watch text wrapping :)

      HTH

    2. Hello there,

      I was looking for a command that hard resets or reloads only the 3G card itself and found this entry. WE have many customers using this card and the cellular interface loses the IP randomly. We try to clear line x and create interesting traffic with event manager but generally it doesn’t work. “test cellular 0/0/0 modem-power-cycle”
      command gave me a great hope but I tried on 5-6 customers and it didn’t work. They push me to reload the router. do you have any other suggestions?

      Best regards.

  2. Hi, I have a 3G-HWIC-GSM card in a 2811 router with the latest IOS. I am trying to set it up as a DDR link but even just trying to get it set up with MTN for testing purposes as a main link all that happens is the link goes up and down the whole time. When I use the simcard in a normal USB modem it works perfectly.

    Not sure where to look anymore and any help will be appreciated.

    1. What hardware version is your radio?
      MTN requires v1.1.9.33, and suggests using either IOS 12.4(22)YB4 or 15.0(1)M. I personally would use 15.0(1)M.
      (I personally have not tested MTN’s 3G with the 3G-GSM.

      Another suggestion I might add to rule out hardware is to try a Vodacom sim. I used the Vodacom ‘unrestricted’ APN, but your testing for outbound/uptime should be fine on their ‘internet’ APN. (Note that a Vodacom sim must be activated (free) for their ‘unrestricted’ APN).
      If the Vodacom sim works fine, I would suggest contacting MTN corporate and request their assistance connecting to their gateways with the 3G-GSM card.

      Hth, else shout :)

  3. HI

    I am currently trying to setup two 3g cards on one router, for failover purposes. I get the “primary” 3g card connected, but cannot failover the routing to the 2nd cards, have you or do you know of possible configs for that.

    1. I’m assuming you got both interfaces up, each getting an IP and its own connectivity to the big bad net? What router are you using?

      See the problem with what you are trying is more with return routing than it is with outgoing.
      It’s will be a messy solution since you have different return ranges routed, but to some degree is possible.
      You will have to rely on NAT out each interface.

      But send me a mail with your configs. I’ll see if I can assist.

      1. I can get the interfaces to come up, primary works, when i shut the primary to get traffic routed via secondary it looks like the natting or routing is not 100%

        cisco 1841
        (C1841-IPBASE-M), Version 12.4(15)T9

        ip nat inside source list 101 interface Cellular0/0/0 overload
        ip nat inside source static tcp 10.20.20.2 21 interface Cellular0/0/0 21
        ip nat inside source static tcp 10.20.20.2 80 interface Cellular0/0/0 80
        ip nat inside source static tcp 10.20.20.2 443 interface Cellular0/0/0 443
        ip nat inside source static udp 10.20.20.2 5001 interface Cellular0/0/0 5001
        ip nat inside source static udp 10.20.20.2 5002 interface Cellular0/0/0 5002
        ip nat inside source static tcp 10.20.20.2 23 interface Cellular0/0/0 23
        ip nat inside source static tcp 10.20.20.1 23 interface Cellular0/0/0 2323

        ip nat inside source list 111 interface Cellular0/1/0 overload
        !
        access-list 1 permit any
        access-list 2 permit any

        interface Cellular0/0/0
        ip address negotiated
        ip access-group 100 in
        ip nbar protocol-discovery
        ip nat outside
        ip virtual-reassembly
        encapsulation ppp
        ip route-cache flow
        dialer in-band
        dialer idle-timeout 2147483
        dialer string gsm
        dialer-group 1
        async mode interactive
        ppp chap hostname ———
        ppp chap password 0 ——-
        !
        interface Cellular0/1/0
        ip address negotiated
        ip access-group 101 in
        ip nbar protocol-discovery
        ip nat outside
        ip virtual-reassembly
        encapsulation ppp
        ip route-cache flow
        dialer in-band
        dialer idle-timeout 2147483
        dialer string gsm1
        dialer-group 1
        async mode interactive
        ppp chap hostname ———-
        ppp chap password 0 ———-

        line 0/0/0
        exec-timeout 0 0
        password void
        script dialer gsm1
        login
        modem InOut
        no exec
        speed 384000
        line 0/1/0
        exec-timeout 0 0
        password void
        script dialer gsm1
        login
        modem InOut
        no exec
        speed 384000

        interface Dialer1
        no ip address
        !
        ip forward-protocol nd
        ip route 0.0.0.0 0.0.0.0 Cellular0/0/0 name Default_Route

        ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 20 name Backup_Route

        2 sims primary active:

        Gateway of last resort is 0.0.0.0 to network 0.0.0.0

        192.168.128.0/32 is subnetted, 1 subnets
        C 192.168.128.77 is directly connected, Cellular0/0/0
        10.0.0.0/24 is subnetted, 1 subnets
        C 10.20.20.0 is directly connected, FastEthernet0/0
        S* 0.0.0.0/0 is directly connected, Cellular0/0/0
        INFHO-RTR-CPT#ping 196.41.197.18

        Type escape sequence to abort.
        Sending 5, 100-byte ICMP Echos to 196.41.197.18, timeout is 2 seconds:
        !!!!.
        Success rate is 80 percent (4/5), round-trip min/avg/max = 364/381/400 ms

        2 sims primary shut:
        192.168.128.0/32 is subnetted, 1 subnets
        C 192.168.128.74 is directly connected, Cellular0/1/0
        10.0.0.0/24 is subnetted, 1 subnets
        C 10.20.20.0 is directly connected, FastEthernet0/0
        S* 0.0.0.0/0 is directly connected, Cellular0/1/0
        INFHO-RTR-CPT#ping 196.41.197.18

        Type escape sequence to abort.
        Sending 5, 100-byte ICMP Echos to 196.41.197.18, timeout is 2 seconds:
        …..
        Success rate is 0 percent (0/5)
        !

  4. Hi,
    I am trying to set up a 3G HWIC card on a 1905 router, and the problem is that i am not able to get a IP address negotiated, however i am able to assign the same IP manually and the ping works fine.. so the problem is that i am not able to get an IP address automatically..
    However,if i install the same card in a 1841, it works just fine with a negotiated IP address..i have matched the configs of both the routers , and they are similar.. Kindly suggest what could be the prblm ..

    Regards,
    Peter

    1. Hello Peter

      The 1905 does support that WIC as per http://bit.ly/bvE4o3.
      Firstly confirm the IOS you using on the 1905 supports the minimum required IOS for the Hwic.
      Secondly I’d check the Bug Toolkit for related errors, It does sound like a IOS being grumpy for no reason.

      hth

      1. Hi Ruhann,
        The IOS i am running on the 1905 is C1900-UNIVERSALK9-MZ,Version 15.0(1)M3,i will try to get it updated and check if it makes a difference… thank you once again for your assistance… please let me know if i need to know anything else also…

        Peter

      2. No probelm Peter.
        I have not used the HWIC on the 1905, but if the documentation says it is supported, it should work.
        Which leads me to believe it might be IOS bug related. Whether known or unknown.
        I hate just recommending a IOS upgrade, but might help here.

        One thing to try perhaps before upgrading the IOS, Use the “debug ppp negotiation” and if that does not yield anything interesting try it with a “debug ppp packet”
        I’d compare that with the equivalent debug from the 1841. Perhaps that can tell why IPCP is not negotiating the address correctly.

        hth

  5. Hi,

    Ihave one remote site linked with MPLS(IDSL), I have implimented a 3g hwic- hspa as backup link succesfuly, the problem come when the primary link goes down(mpls)the backup interface (3g) does not pick automaticaly, please assit.

    Regards
    Elius

      1. Hello from Spain. I have the same problem than Elius. I have a Cisco 2801 witch hwic 3g and one of the interface fast ethernet is conected to vodafone ADSL Router. When the ADSL goes down or enven i do a shutdown on fastethenet interface, the cellular interface not goes up.

      2. Hello

        The cellular interface needs interesting traffic to come up. Since its down the floating default route pointing out that interface is not present in the routing table. When the primary route goes down, the router drops the traffic. (chick and egg scenario)

        My advice, add two “ip sla monitors”.
        The 1st one should test far end reachability out the ethernet interface to vodafone to know when your DSL goes down. The 1st ip sla monitor should have a “track” tied and the “track” should be watched by the primary default route(normal AD). That way if your DSL goes down the floating static should be used for default routing. (since it will have a higher AD)

        The other “ip sla” should be pointing out the cellular interface to the GSM network. With a frequency of 15-30 seconds, the cellular interface should stay up. This sla is used to keep the interface appose to verify reachability, so no “track” required. Since the cellular interface is up, the floating static route pointing out the cellular interface, is always available to become active immediately when the primary default route gets removed.

        That should take care of the fail-over and teh fail-back.
        The second part that is crutial is NAT. You must outbound nat and tie it to the interface else your traffic will never know where to return to.

        HTH

      3. Hi Ruhann.

        Thanks for repply my post.

        I posted you my running-config from my Cisco Lab.

        With this router four years ago i passed my CCNA and CCNP exam. Like you can see, there are floating static routes, and backup interface and backup delay in the interface fastEthernet 0/0 connected to the Vodafone Router. its extrange for me that this config doesnt work.

        I have been look your post, and i have read on Cisco webpage “IP SLA”. Nevertheless, i would like if its posible for you
        posted me the perfect config to work. The IOS installed doesnt support RTR command to configure tracked objetc number :,,(

        vpn(config)#track 234 ?
        application Application
        interface Select an interface to track
        ip IP protocol
        list Group objects in a list
        stub-object Stub tracking object

        Cisco IOS Software, 2801 Software (C2801-ADVENTERPRISEK9_IVS-M), Version 15.1(3)T, RELEASE SOFTWARE (fc1)
        Cisco 2801 (revision 6.0) with 241664K/20480K bytes of memory.
        Processor board ID FCZ11022060
        3 FastEthernet interfaces
        1 terminal line
        1 Virtual Private Network (VPN) Module
        2 Voice FXO interfaces
        1 DSP, 8 Voice resources
        1 Cellular interface
        DRAM configuration is 64 bits wide with parity disabled.
        191K bytes of NVRAM.
        250880K bytes of ATA CompactFlash (Read/Write)

        interface FastEthernet0/0
        ip address 192.168.0.50 255.255.255.0
        description #### TO VODAFONE ROUTER WAN – PRIMARY LINK – ####
        backup interface dialer 1
        backup delay 10 10
        ip nat outside
        ip virtual-reassembly in
        duplex auto
        speed auto
        !
        interface FastEthernet0/1
        ip address 192.168.200.1 255.255.255.0
        description #### LAN ###
        ip nat inside
        ip virtual-reassembly in
        duplex auto
        speed auto
        auto qos voip trust
        service-policy output AutoQoS-Policy-Trust
        !
        interface FastEthernet0/1/0
        no ip address
        shutdown
        ip nat outside
        ip virtual-reassembly in
        duplex auto
        speed auto
        !
        interface Cellular0/3/0
        no ip address
        ip nat outside
        ip virtual-reassembly in
        encapsulation ppp
        dialer in-band
        dialer pool-member 1
        dialer-group 1
        async mode interactive
        !
        interface Dialer1
        ip ddns update elMetodoParaActualizarDDNS
        description #### WAN MOVISTAR – SPAIN – SECUNDARY LINK ###
        ip address negotiated
        ip nat outside
        ip virtual-reassembly in
        encapsulation ppp
        dialer pool 1
        dialer idle-timeout 180
        dialer string inet-movistar
        dialer-group 1
        ppp chap hostname xxxx
        ppp chap password 7 xxxxxx
        !
        ip local pool POOL 192.168.200.100 192.168.200.105
        ip local pool NAT 192.168.0.101 192.168.0.110
        ip forward-protocol nd
        ip http server
        ip http authentication local
        ip http secure-server
        ip http secure-trustpoint xxxxxx.com
        ip http path flash:GUI
        !
        !
        ip nat inside source route-map NATCELLULAR interface Dialer1 overload
        ip nat inside source route-map NATVODAFONE interface fastethernet 0/0 overload
        !
        ip route 0.0.0.0 0.0.0.0 fastEthernet 0/0
        ip route 0.0.0.0 0.0.0.0 Dialer1 200
        !
        !
        logging esm config
        access-list 1 permit 192.168.200.0 0.0.0.255
        access-list 10 permit 192.168.200.0 0.0.0.255
        dialer-list 1 protocol ip permit
        !
        !
        !
        !
        route-map NATCELLULAR permit 10
        match ip address 1
        set interface Dialer1
        !
        route-map NATVODAFONE permit 10
        match ip address 10
        set interface FastEthernet0/1/0
        !
        !

      4. your version of IOS 15.1 must support IP sla. I dont have access currently to a device with that IOS or one with a GSM card, but you config should look something like:

        ip sla monitor 1
        icmp-echo {vodafone-ip} source-ip {vodafone interface ip}
        frequency 30
        ip sla monitor schedule 1 life forever start-time now
        !
        ip sla monitor 2
        icmp-echo {gsm-ip} ! make sure this ip is routed out the dialer interface
        frequency 30
        ip sla monitor schedule 2 life forever start-time now
        !
        track 1 ip sla 1 state
        !
        ip route 0.0.0.0 0.0.0.0 Dial0 240 name gsm
        ip route 0.0.0.0 0.0.0.0 Fa0/0 10.1.1.1 track 1 name vodafone

        hth

  6. Hi Ruhann

    I think there’s a typo in the beginning of the post:

    line 0/0/0

    script dialer GSM

    The script name is case sensitive and then in the rest of the configuration you use “gsm” and in the chat definition too. At least in c1841-advipservicesk9-mz.124-22.T.bin

    It has been driving me nuts for two days until I realized looking at the logs :)

    The rest of the post is perfect! Keep up the good job!

    Cheers

  7. Hi, really interesting post.
    Actually I am looking for out of band management options and this seems to be advanced and cost effective solution as compare to others.

    But I have below concerns, hope you can answer this.
    what if routers power goes down? Still I would be able to access the router via 3g by any chance?may be some hidden facts?

    If my primary link fails, I could access the router via internet? what about security here?

    Also let me know which technology you will prefer for OOBM for management of 500++ cisco routers around the globe.

    1. Hello Frank.
      Unfortunately if you loose power, you will lose access to the router and 3G card. No fancy stuff available there.
      You can another link as a backup if the 3G dialer interface fails, but that does increase the complexity, and adds another dimension to the security requirements.
      For the amount of sites you listed and them being global, 3G connectivity might not be the best option as different carriers in different countries operate differently and provide vastly different services.
      I would suggest looking into the solutions that a company like http://www.avocent.com has to offer.

      Hth :)

  8. Hi,

    It has been really very intersting to go through all of your tips which are really very helpful. I have a HWIC 3G card installed installed and now planning to get a dedicated ethernet link from my provider which will have a static public IP and will act as a primry link and the 3G link will be the back up. Just want to confirm whther there is any other way other than IP SLA and EEM script to accomplish this instead of using any any inbuilt feature of Cisco IOS.

    Appreciate your prompt response.

  9. Guys,
    Need your urgnet help ….
    My Sim is activated for very short time just couple of random times,but except that and most of the time its always INACTIVE,here is the configuration:
    ************************************

    !
    !
    multilink bundle-name authenticated
    chat-script modem “” “AT+IPR=9600″ timeout 5 ok “at&w” timeout 5 ok
    chat-script voda “” “AT” TIMEOUT 5 OK “ATE0V1″ TIMEOUT 5 OK AT+CGDCONT=1,”IP”,”mashreqbank.vodafone.net” TIMEOUT 5 OK “ATS0=0″ TIMEOUT 5 OK “AT+CGATT=1″ TIMEOUT 5 OK “ATD*99***1#” TIMEOUT 10 CONNECT
    chat-script ping ping 10.222.246.169
    !

    !
    interface Tunnel1
    ip address 55.55.55.2 255.255.255.252
    ip mtu 1476
    tunnel source 10.222.13.1
    tunnel destination 10.222.246.169
    !

    !
    interface Cellular0/0/0
    ip address 10.222.13.1 255.255.255.0
    encapsulation ppp
    dialer in-band
    dialer string gsm
    dialer-group 1
    dialer idle-timeout 0
    async mode interactive
    ppp authentication chap pap callin
    ppp chap hostname gsm
    ppp chap password 0 1234
    ppp ipcp dns request
    !
    ip route 10.222.246.169 255.255.255.255 Cellular0/0/0

    !

    !
    ip sla 10
    icmp-echo 55.55.55.1 source-ip 55.55.55.2
    ip sla schedule 10 life forever start-time now
    access-list 1 permit any
    dialer-list 1 protocol ip list 1
    !
    !
    control-plane

    line 0/0/0
    exec-timeout 0 0
    script startup modem
    script dialer voda
    script reset ping
    script activation voda
    modem InOut
    no exec
    *****************************
    Tried pinging and debug ppp packet and debug ppp nego,nothing changed/displayed,what are your thoughts?

  10. Guys I have an 1841 router with a 3G hwic card, the problem I am having is that my download and upload speeds are absolutly slow, when I use the same sim on a USB dongle the speedsa are 10 time faster I also see on a show cellular 0 all the packet service is edge even if I am in an area that has excellent 3g I upgraded the firmware on the hwic to 1.9 and I am running advanced enteprize ios on the router…any help please

  11. how to set the Cellular Band:

    cornec-dsl887#cellular 0 gsm band wcdma-all-bands

    i have no idea what’s the default

    before (very sad face ;( 10 KB/sec for losers )
    cornec-dsl887#show cellular 0 radio
    Radio power mode = ON
    Current Band = GSM 900, Channel Number = 41
    Current RSSI = -74 dBm
    Band Selected = Auto
    Number of nearby cells = 1
    Cell 1
    Primary Scrambling Code = 0x3D
    RSCP = -89 dBm, ECIO = -6 dBm

    after (fuck ye happy face :D 100KB/sec for the less frustrated)
    cornec-dsl887#show cellular 0 radio
    Radio power mode = ON
    Current Band = WCDMA 2100, Channel Number = 10562
    Current RSSI = -97 dBm
    Band Selected = WCDMA All(800/850/900/1900/IMT 2000)
    Number of nearby cells = 1
    Cell 1
    Primary Scrambling Code = 0x1E3
    RSCP = -98 dBm, ECIO = -11 dBm

  12. Hi everyone
    I have one sim card, and use a Cisco 880G
    Do i need to configure both sim card slots ? or Can i use any slot to insert my sim card , it does’nt matter?
    Thank you for your help
    Hung Caoduc

  13. Hi I have configured HWIC 3G GSM interface when i reload the router it works fine after some time interface reset and nothing work when i ping 8.8.8.8 no replay actually the interface is getting IP address can please help me.

  14. I Have few Cisco C841M-4X/K9 with flash:c800m-universalk9-mz.SPA.155-3.M.bin. All the location are having similar issue, Radio band goes to Unknown State. I tried forcefully giving technology as GSM, after reboot again the Band is getting selected as auto or unknown.

    Radio power mode = ON
    Channel Number = 0
    Current Band = Unknown
    Current RSSI = -78 dBm
    Current ECIO = -14 dBm
    Technology Preference = AUTO
    Technology Selected = HSDPA (Downlink) and HSUPA (Uplink)

  15. Hi

    I have an issue that I just cannot seem to solve. I am setting up a 3825 router with a 3G HWIC as backup to a Gigabit ethernet port.
    When I unplug the ethernet port the modem does it’s thing correctly and connects and all is well. However, when I plug the ethernet cable back in the ethernet becomes primary, the cell interface goes back to being secondary standby, the gi0/0 gets an IP address from the modem, but the router does not seem to begin routing. (ie all the connected computers on the cisco 3750X do not get re-connected to the internet)
    I am not sure exactly what is wrong. Any assistance would be appreciated.

Please leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.