Troubleshooting Vlan Issues

There are many ways to troubleshoot VLAN issues, and although this article is not meant to replace the understanding of conventional switching and vlan issues, and how to troubleshoot them, this approach will certainly come in handy.

I make use this a lot in our large data centres, and it is often enough to isolate the problem to a single link or trunk.

For illustration purposes, suppose the following really basic scenario:

sw-vlan1

>

Router1’s Ethernet interface can’t ping R4’s Ethernet inteface in subnet 10.1.0/24.

r1-broke-both

Assume the config on R1, R4, SW1, and SW4 is as follow:

R1#sh run int fa0/0
interface FastEthernet0/0
ip address 10.1.0.1 255.255.255.0

R4#sh run int fa2/0
interface FastEthernet2/0
ip address 10.1.0.4 255.255.255.0

SW1#sh run int fa0/1
interface FastEthernet0/1
switchport access vlan 123

SW4#sh run int fa0/4
interface FastEthernet0/4
switchport access vlan 123

Since connectivity between R1 and R4 is pure layer 2, conventional troubleshooting would be required on each access and trunk link. By creating a L3 SVI (Switched Virtual Interface) and assigning an available IP to that interface, on a switch in the switching path, you can easily elimate the working portions between R1 and R4, and isolate the problem area to minimize your time spend finding your mistake.

For example:

SW1#
configure term
interface Vlan123
ip address 10.1.0.21 255.255.255.0
end

SW1#ping 10.1.0.1
Sending 5, 100-byte ICMP Echos to 10.1.0.1, timeout is 2 sec:
!!!!!
Success rate is 100 percent (5/5)
SW1#ping 10.1.0.4
Sending 5, 100-byte ICMP Echos to 10.1.0.4, timeout is 2 sec:
. . . . .
Success rate is 0 percent (0/5)

This confirms that between SW1 to R1, the interface is up and configured correctly, thus the problem lies between SW1 and R4.

If however the Ping from SW1 to R1 failed,

  • confirm the Vlan is active on SW1 by using ‘sh vlan id brief
  • confirm the Vlan is correctly assign to Fa0/1 by using ‘sh vlan id 123

Assume we do the same on R4 and have similar successful output, we will know that the problem lies between SW1 and SW4. If we then create the SVI on SW2 we will be able to isolate the problem to either link  SW1-to-SW2,  or  SW2-to-SW4.

Once the problem link is isolated, confirm the following:

  • Is the Trunk UP and configured with the correct encapsulation on both sides?
  • Is the Vlan active and allowed on the trunk?
  • Check by using ‘sh int trunk
  • Confirm that Spanning tree is working correctly: ‘sh span vlan 123

Add to FacebookAdd to NewsvineAdd to DiggAdd to Del.icio.usAdd to StumbleuponAdd to RedditAdd to BlinklistAdd to Ma.gnoliaAdd to TechnoratiAdd to Furl

Advertisements

One thought on “Troubleshooting Vlan Issues

Please leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s